Connection to Beta API Not working

I identified the IP address of my BOND on my local LAN and tried to query the version and also tried to query for an application token. Both attempts failed per below:

Token is only available in the first 10 minutes after a hard reboot. Just checking that you did do the hard reboot before attempting to get the token?

Also, make sure your app shows a firmware version of 2.x.x

I performed the reboot and then queried the device about a minute after it showed online.

Hmm…my Bond is now saying it has a new version of Firmware which is version which is v1.138.1 and it shows me on v1.117.7. So, the version they are talking about is the firmware and not the device? This still does not seem like v2.x. By the way, I have tried to update the device many times over the last months and it usually runs for 30 minutes and then nothing happens.

Ah, then I’m sorry you won’t yet be able to use the Local API.

The 2.x.x firmware is a closed beta, and I believe they are not currently accepting new testers.

@residualimages, It finally look the update and now says that I am running v1.138.4 and that I am up to date. Is the version 2 a hardware version perhaps?

No, they do push the v 2.x.x firmware to original hardware BONDs that are accepted into the beta.

However, there is a hardware revision (serials start with ZZ) which comes with v 2.x.x firmware out of the box.

I performed the update, however as you notice below, I am at v1.138.1 now and in checking for a firmware update I am told that I am at the latest version.

Hopefully there will be some progress relatively soon in getting this made available to more people.

The serial number on my Bond begins with the letters “AJ” and not “Z” or “ZZ”. What does that mean in terms of the v2.x.x firmware?

Closed beta. I thought that I was in the beta group. That and I got an email specifically addressing the new public API.

This will explain - if your serial number does not start with ZZ (as in your case), you will get the v 2.x firmware update once it is publicly released.

It is in a limited, invite only, closed beta release for now, unless you happen to have a ZZ serial number BOND; only in that case would you not need an invite to the closed beta.

@vmsman: Hey Scott! So great to have you on the community! — The PBB unit we shipped you (serial number starting KM) also works with the Local API as documented.

Your BOND Bridge with serial starting in A or B will need to be upgraded to V2 firmware before the Local API is available. That firmware is not very stable at the moment for the earlier hardware, but we are working on getting it production ready.

1 Like

So, my serial begins AJ. What does that mean?

@vmsman The important thing is, the Local API is only available on v2.x.x firmware. — V2 firmware for AJ units is not public yet. Not yet stable enough.