Bond keeps Wi-Fi AP active, why?

even after connecting my Bond device to my home wi-fi network I continue to see the Bond device Wi-Fi access point being being advertised, why is this?

If the device is connected to a wi-fi network this should turn off. All it’s doing is providing unnecessary noise on the already crowded 2.4GHz airwaves.

Apparently you can’t even change the channel it uses either?

It’s probably not connected to our backend. (MQTT broker, specifically) Presumably it doesn’t work when you’re not on your home network? Or maybe you’re using another device locally that in turn controls the bridge?

If you intend for it not to be connected to our backend, you’re not alone, and we have an “offline” mode in the backlog. This’d just be a flag that suppresses two bad behaviors when not connected to our backend: rebroadcast of the config AP, and reboot after a timeout.

If it is connected to our backend, then that’s a bug. Could be that the Bond doesn’t realize it’s connected. Basically if it’s connected, the AP should be hidden.

It’s configurable but we haven’t documented it, assuming lack of user interest. The intent is to only broadcast on setup.