Bond Bridge Error 103

When checking for Firmware updates on my devices it returns Error 103. The Bridge is working fine in regards to operating my ceiling fans.

I’m having the same issue except that one of my 5 fans doesn’t respond to Bond commands now, which was the reason I checked the firmware.

I had this happen a couple times, but I’ve resorted to multiple attempts to check for and perform updates, and usually the 2nd or 3rd time in a row does it. I haven’t even had to try rebooting and immediately pinging for the update or anything.
@Trial_Master / @LibraryDragon - is it repeated failures no matter how many multiple back to back times you try to check?

What firmware versions are you on at the present time?

@LibraryDragon - for your fan that stopped responding, have you started a thread here about that, or as a more official and timely support option, have you used the in-app help chat or sent an email to

Hey guys - we found the cause of the error showing up. Bond bridges that do not start with Z rely on an S3 file that became private on a recent update. This change led the apps to believe there was an update available and also caused failure during the update process.
We made the file public again and we’re deploying a fix for some edge case scenarios on the apps to avoid falsely showing the “Firmware update available” indicator in the next app release (v2.32.0).

1 Like

@residualimages My app still shows the “1” update indicator but when I tap “Firmware Update” I no longer receive the “Error 103” message; instead, I get a message that I’m up to date.

In an attempt to fix the non-responsive fan, I had deleted it from the app and tried to add it again. I had been unable to add it back all day. After seeing the post from @natan, I tried again and was able to add it manually. Thanks for the quick response and resolution everyone!

1 Like

All good now. Thanks for getting back to us with resolution.

1 Like