[Solved] V2 Failed during update. Bricked?

My V2 Powered by Bond device failed during a firmware update and appears to be bricked. I tried a power cycle with no change in behavior.
Error messages received:
Error: Oops Something went wrong
Error: 2 exceptions occurred

Screenshot of logs during failure attached.

Have you physically power cycled (cut power) from that fan? I had one failure originally several weeks ago, and power cycling the actual power to the fan, as well as force-stopping the Android app allowed me to continue the setup / update.

I know you said you power cycled but wasn’t sure which method you used. Assuming switch at the wall but…?

1 Like

I cut the power to the fan at the circuit breaker for approximately 10 minutes… no dice :frowning:

Force stopping the app, removing / reinstalling the app, and factory resetting the phone didn’t help either.

Indeed what occurred is an incompatibility between the new firmware and units from the KMBL production batch.

Luckily, all BOND products support an “anti-brick” function!

You will need to “rescue reset” it as follows:

  1. Disconnect the product from power, using a wall-switch or circuit breaker.

  2. Wait 5 seconds.

  3. Start holding down the “Breeze” button on the remote control.

  4. Reconnect the product to power.

  5. Continue to hold the Breeze button until the Light flashes ~7 times. This takes about 15-20sec.

  6. Now the “BOND Config KMBLxxxx” network will re-appear, and you can set up on WiFi again.

The above “rescue reset” erases all content and settings on the device, as well as reverts to the original firmware version programmed in the factory.

1 Like

Awesome! Will perform the Rescue Reset asap!

Revise Reset worked perfectly and the fan successfully updated the firmware.

1 Like