[Snowbird] Firmware Improvements Needed

I have a growing list of issues with this product. It worked great when I initially bought it.

When I decided to improve my home network security, I added a separate SSID for smart home devices and hid the SSID. The Bond Bridge does not support hidden SSIDs at all. This is a major oversight in development as this is a fundamental wireless function. This is the ONLY device in my house with this issue.

The hidden SSID issue has remained through the new V2 overhaul/changeover. In addition, trying to manually add an SSID or do anything via the built-in web interface is a terrible experience. If you try to manually put in SSID information it asks for a router MAC which seems like an absurd field for input. Again something I have never seen in any other device. This is what DHCP is for.

Once you power up the device you can get access to the network configuration settings via the built-in web interface, but after 10 minutes it locks this interface and requires a PIN. The PIN is located on the bottom of the bridge. However, there is no button to submit the PIN entry to get into configuration mode! The only way is to put in your account code and then it will try. However, I have still not been successful in getting that to work. This leads to the next issue.

The Bond Bridge does not appear to respect my DHCP DNS configuration settings. I run a local DNS setup (pi-hole and pfsense) and force all DNS traffic through the pi-hole. (Currently by blocking all other DNS destinations.) When I go into the web interface for the bridge, it shows that it is using (Google) for DNS. According to my firewall logs, it tries,, and non-stop and, from what I have seen so far in my query logs, never attempts to use the DNS server it received via DHCP. - Yes, Google devices (Home devices and Android phones) are also notorious for using their own DNS, but they at least respect the DHCP configuration and use the server even if they are still constantly trying to use their own.

I’m still trying to determine exactly what it is and isn’t doing via DNS, but I wanted to put this information out there in hopes that some of these fundamental improvements can be made.

What’s the first letter of your Bond serial number? Units starting with A/B use a WiFi chipset where the driver is closed source and buggy when pushed outside the “norm”. So sadly there’s not much we can do, we have been shooting in the dark with ioctls…

The new Z (“Zermatt”) hardware uses a superior WiFi chip and actually respects hidden networks, and the DNS should work properly.


A closed system would indeed make it difficult to work out issues.

I have a B s/n Bond unit so I guess that would explain a lot of my issues.

Update: I worked with support for an exchange from my B sn to a Z sn and it’s made the world of difference. I had the new one connected and working way faster than even the original setup when I first bought it.