Schedule Issues

Recently tried to set my patio fan light to turn on and off via the schedule feature. All works except the turn light on schedule function. Odd part is the indicator turns green within the app showing the light is on but the light itself does not turn on. Turning the light off works as is should along with turning the fan on & off. Using remote template RCF94v2 with Fanamation Blitz model #LP8377

Tried it with both stable and latest beta firmware, same result. One other note, using the latest beta firmware and trying to do a back up restore shows the missing content-length error again but does not via the stable firmware. Not sure if this is related or not.

Thanks :+1:

Motorola Edge Plus
Android 11

I seemed to have possibly fixed the problem.
I removed and added the fan back to Bond, adding the commands 1 by 1 and slowly testing as I went, I did have to remove and add back the Power Off and Speed 3 commands twice.

Back story, I purchased the Bond device back i March 2021, it never worked right and I put it aside, fast forward to Jan 2022 and when I powered the Bond device on again there was a firmware update. So I tried to settings again, fan still had the same issue of Not Powering On in the AM by schedule…

Glad to see by removing the adding the Fan and commands again seems to have fixed my issue. I will report back soon is this really did fix the issue.

1 Like

Hi @KMDonlon !

When you control your fan using the Bond Home app, does it works all the time or does it miss sometimes?
Maybe the template is not exactly the best one for your Fanamation model… Do you know the FCC ID of your remote? It is usually written in the remote, something like this:
(Picture from Google)

Also, about the “Missing content-length” issue on backup at beta version, thanks for reporting it! I’ll work with the team to get it fixed.

It works all the time, no issue whatsoever. Like I said, the fan on & off work fine via the schedule. Also, the light off works perfectly too, just the turn on light.

My FCC id is KUJCE10711.

Thanks you for your response :grinning:

Thank you for all the info!

Very interesting… Is it possible that the fan was controlled using the physical remote control?
The Bond is not able to keep tracking of the fan state when controlled by the remote right now, so what could happen is:

  1. Turn the light off using the remote control
  2. Bond believes the light is still on
  3. Schedule to turn light on triggers
  4. Bond doesn’t transmit the signal because it “is already on”
  5. Lights doesn’t turn on, but the app still shows it as on

If you’re able to do some more tests and have some spare minutes, try adding schedules to some minutes ahead and check the behavior.
I can look into the Bond logs, but I need your permission, the Bond ID, and the time of the events. Feel free to send me a message to make it more private.

I’m also contacting the engineering team responsible for the remote templates to be sure that RCF94v2 is the best fit for your model.

1 Like

I appreciate you looking into it. I have tried setting it ahead multiple times to verify the issue. The physical remote was also tried as you suggested to no avail.

App will show light as OFF prior to showing ON when the schedule feature triggers it, just doesn’t actually turn the light on. The OFF schedule works just fine and will shut the light off perfectly every time.

When I have more time I can certainly give you permission to look through the log files.

All else is great, just seems to be this one little bug…

Maybe it is worth mentioning that I and @KMDonlon worked together with other Bond team members and got it working!

The fix is not publicly available yet, but if anyone else got issues with the RCF94v2 template please let me know.

Thanks for your patience, for using Bond, and for working with us on the fix!