Light State Tracking Broken?

Hi there,

I have, for several firmware versions now, had issues with light state tracking. This used to work correctly at some point in the past. Using the local API, I could issue an API command to turn off the light, and if it was already off there would be no action (expected behavior). But now, whenever I make an API call to turn on or off the light, it just toggles it, regardless of the state. This is really annoying when I run my “go to sleep” automation routine and it turns all the other lights in the house off, then turns on my fan light (right above my head) at full brightness.

I have enabled the “Trust Tracked State” option for both of my fans, and I can see that it’s enabled when I query the API to get device properties. It just plain doesn’t work though.

Is anybody else running into this same issue? Are there any workarounds, or is a fix coming soon? I was making good progress on developing my integration for Home Assistant, but my hub is pretty useless to me if it just randomly toggles lights and I can’t actually tell if they’re on or off.

I’m running v2.10.8-beta on my hub currently.

Thanks in advance!

I’ve got v2.10.8 on my Bridge, and I just tried experimenting with turning Trust State on/off for my kitchen fan. — Seems to work just fine. With Trust State OFF, the Toggle is always sent. With Trust State ON, the Bridge always does the right thing (unless of course the state is mismatched, in which case it always does the wrong thing.)

If you’re still running into trouble after giving it another look, let me know and I’ll try to help you debug it live.

Hey there, it was working in the past for you with the same setup, right? Could you PM me your Bond ID, if you share some info with me I can recreate your setup and see what’s going on here.

1 Like

Thanks for reaching out! I DM’d you

@jacob Any chance you’ve been able to make progress on this?

Hey, yeah, I have identified the problem and aim to fix it today or tomorrow. I’ll update you here as I progress.

1 Like

Awesome! Thank you so much!

Hey, just checking to see if I need to do anything on my end to get the fix?

Thanks!

Sorry, I haven’t forgotten you, I’ve been recovering from the flu. It’ll require a firmware update. I’ve got most of the work done here, I just need to polish things up.

Thanks! Sorry to hear you weren’t feeling well. Just checking to see if there’s any update on this?

I vastly underestimated how big of a project it was… the “polishing things up” turned into “rewriting half of the actions API”… but I finished a draft yesterday! We’ll just do a bit of internal testing to make sure there’s nothing completely broken, then get it to beta. Are you signed up to receive beta app versions?

1 Like

Yes I am! I’ve been checking regularly to see if there’s an update.

I know how that goes. I’m a software developer as well, and sometimes we don’t initially realize how deep the rabbit hole goes…

I appreciate the update and look forward to trying the new beta!

Well, I, and others, can empathize 100%.
Happy to hear you’ve probably got it licked, now!