Fan Light turning on by itself

Hello,

I’m wondering if there is a log file that would allow me to see information about why a device is triggering? I’ve setup a ceiling fan and I can control it perfectly, the alexa integration is working great. However, when I go to sleep all the lights are off and when I wake up the ceiling Fan Light is now on.

I’m trying to debug and figure out why and how that is happening.

Any ideas?

Tim

@endy - I cannot find Usage History in the Bond app any longer - was it removed? I thought I saw a post about it having some issues but I cannot find it now.

@TimN - if you contact support (customerservice@olibra.io), they may be able to help. It would be helpful to them if you had a time range, though I know when you’re sleeping it’s hard to know exactly.
They will also need your serial number of the Bridge (if that’s what you used to record the original remote), or ceiling fan receiver if it is a SBB (Bond integrated) fan.

1 Like

Awesome, thank you. I’ll do that.

@residualimages You’re right.
We removed the Usage History for some maintenance. Unfortunately, we don’t have an estimated time to get it back, but we’re working on it!

@TimN Do you know if your device has the trust state feature enabled? You can check this on the Device Settings screen.
This feature prevents wrong state changes, like turning the lights off when you’re asking to turn the lights on because it was already on.

If you enabled this feature and the issue persists, let me know here and I’ll work with the support team to investigate it further if it is ok for you.

endy,

I am having the same problem, 2 different fans, lights and fans turn on at random. I have a ticket open (51006), and was directed to this post by Lorraine. The “trust state” feature was NOT enabled for either fan. I enabled it, and will continue to monitor. Thank you.

Hi @dbarger !
I’ll be glad to help.

I believe the trust state will make it, but want to include some other info.
Looks like Alexa has a hunches feature that may be influencing the fans’ behavior, mainly when the command is “toggle” and the trust state is disabled.

This is the Amazon documentation to check if it enabled and turn it on/off:
Turn Hunches for Your Smart Home Devices On or Off

Let me know if you have any updates or questions =)

Hi @endy !

I checked, and DO have “hunches” enabled through the Alexa app, but I’m not sure if this is relevant to my problem. As part of my earlier troubleshooting, I completely removed the fan/devices from Alexa, and deleted the Bond skill, so Alexa had no knowledge of the devices. The problem still persisted.
I’m going to monitor the fan performance with trust state enabled. If the problem persists, I will turn off “hunches” in the Alexa app. I’ll keep you posted. Thanks for your help!

1 Like

I’m testing one more night. I think I found my problem. The fan was included in a group that I didn’t realize called all lights, in alexa. However, since the light is a toggle switch, when the fan was already off, turning all lights off would turn the fan light on. That’s my working theory, and I don’t know if trusted state will fix that? If I enable trusted state, will it track the light being on or off for me?

Thanks,
Tim

1 Like

Yes. That’s the intention.

Of course, if you use the factory remote, or one of the toggle signals misses, the Bridge will be out of sync.

1 Like

That fixed it. Turning on trusted state resolved the problem.

1 Like