Lag (2-3 seconds) in my setup

So I converted from smartthings to hubitat in hopes the hardware change alone might help various things. Most issues indeed were resolved but one remains. I have my bond setup with my zwave + switches to turn on and off my fan. There’s about a 2-3 second delay from button push to light change, wondering if this is normal or if there are things I can try to get it closer to what I see when changing in the app or remotes.

Just for clarification, I think I’m hearing you say that when using the Bond app or the original OEM remotes, the light change is more or less instant.
However, with Hubitat, there is noticeable (2-3 second) delay somewhere in the path from Z-Wave switch physically changing to Hubitat registering that to Hubitat handing off to Bond (via API integration) a call to change the light.

yes, this is 100% what I am trying to say

Just fixed in v2.29.2.1-beta.

I’m only seeing this…

1 Like

If the delay isn’t there in the Bond app but is there in the API calls that Hubitat is making, is that expected to be fixed with the firmware, @merck - or is it something the Hubitat community / integrators need to examine in their methods?

Edit: also based on @smckdwn989 's screenshot of beta FW version, looks like a Zermatt revision Bond Bridge.

Indeed. The v2.29.2.1-beta only applies to Snowbird Bridges. Current (last 2+ years) Bond Bridges with serial numbers starting with Z are not effected by the delay problem we were discussing on the other thread.

For the current Bridges, there shouldn’t be much of a delay when operating most devices. Of course we cannot in principle do better than the remote control. Bond’s latency on top of the remote control should be less than about 250 ms.

I’m wondering if my issue has to do with the fact that I’m using a zwave switch to trigger the change. If I use the app or remote it’s pretty much instant

Can you share a snippet / screenshot of how you’re making the zwaveswitch<>Bond connection?

My stab-in-the-dark guess is that you’re using mDNS resolution on every request, which is very slow for some reason. Better to use the IP address directly.

Sure so I am using the bond integration and a simple rule like this…

I can’t figure out how to natively use rule manager for a put request so I used webcore and did the following. The delay is still present.

Thanks for sharing this @smckdwn989
I suffered from a ~2 sec. delay in toggling the lights of my ceiling fan, as part of a routine in Smartthings (Ikea Tadfri remote button pressed → Bond wifi Ceiling Fan light toggle).
Created a Webcore that sends a PUT request, and this is now responding dramatically instant.

i’m glad it worked for you, for whatever reason this isn’t working on my end, it’s about the same (2-3 second delay)

That’s interesting, and will most likely require further troubleshooting.
First, I think I would have tested the PUT request independently, via Postman or a simple CURL command in your local network. If that works, your next suspect is the switch, as the ‘on’ state might be incorrect.

so when I run

curl -H “BOND-Token: a67ff25ca797820d” -X PUT -i -d {}

it’s nearly instant.

alright so I set up a virtual switch that fires from the GE zwave switch and the delay is 3-4 seconds. I then tested it against an old zigbee switch which is 1-2 seconds… i’m not sure if my code can be improved but i’m tempted to swap out my ge switches for some kind of scene control zigbee, any recommendations?

Well that tells us that theres not a delay on the Bond side.

From the code you shared, I see you’re using IP address directly. So that means there’s no mDNS delay possibility. Must be something on the Hubitat side.

So I’m switching to lutron picos, from what I gather the consensus is the ge switched just aren’t that responsive.