Command signal lag time

Does anyone else have inconsistent and sometimes pretty long lag times when controlling devices? Usually, devices respond in about two seconds, which is already annoyingly long but sometime it can take 6 or 7 seconds. About the only connection I can make is that sometimes it seems to take longer if I haven’t controlled the device for a while from Bond but that doesn’t always correlate. his is really annoying because most of the time I use wall mounted Lutron remotes through Home Assistant and the delays (even 2 seconds) are just long enough to make someone think it is not responding and hit the button again only to have the light turn on and the off again several seconds later. I thought I was just getting delays going through HA but I started testing using only the app the last few days and the delays are exactly the same. I’ve tried re-adding devices and updated the firmware yesterday to no luck. Is this a known problem? A defective hub?

I know the Picos seam to repeat the command several times to ensure it gets through, I had luck by delaying the results by a quarter second in the hub (although I use Hubitat).

Location Location Location. Have you tried to move your hubs. Both bond and lutron my be running into some interference. I had to put my bond hub higher but still needed in sight of my IR fireplace. Since the move no problems.

I have tried moving it but that doesn’t change the response time. I can put the fan remote right next to the hub and immediately get a response using the remote but still have it take several seconds to respond when using the hub through the Bond app. The hub is on a high shelf now and only about 8 feet from the light I usually control. There are no obstructions so it should have no problem from that distance.

I have a very vague memory of someone on the forum having issues with the USB power supply (adapter or power strip plug or maybe the cord itself) they were using causing some oddities. Have you tried swapping any of those around already while you’ve been moving the Bridge and testing other things?

Also, I wonder if the Bond staff can assist; have you tried to use the Support chat feature in the app during business hours? Or you can send an email to to open a ticket.
Either method might get you in touch with someone who can work with you to see the timestamps vs real world lag.

I haven’t tried anything with the power supply, that’s a good idea. I wanted to make sure I wasn’t missing anything obvious before opening a ticket. I also wasn’t sure if Bond support is the type that just tells you to go the forum after telling you to try all the obvious stuff you already tried.

I completely understand!

I will say my personal experience has been that the Bond team uses the forums as a nice-to-have mainly community driven supplement instead of an alternative to providing good support.
They’re a small team but eager to help - and they do often drop by here sporadically as well. :slightly_smiling_face:

@dubious Does your serial number start with A/B or with ZZ/ZP?

Also, what firmware version are you on.

(There was another post on this forum about a transmit delay in the A/B units after the recent firmware upgrade. Root cause not yet determined. The A/B units are end of life (have not been manufactured in 2+ years), so updates for them are a lot slower.)

I am on the newer hardware (ZZ). When I went to test it a few weeks ago I noticed there was another firmware update (2.28.0) so I installed that and haven’t noticed the really long delays since. I’m not sure if it was that firmware update or something random but everything seems to be working okish now. The hub appears to be sending the signal almost immediately based on the blue light, although I did not specifically check that before so I don’t know if it had been delayed. I think it was that same other post that had a comment about turning up the brightness on the light to see when it was sending the signal.

It still takes longer (a second, maybe two) for the light to respond to the signal from the hub vs pushing a button on the factory remote (Hunter G0878-01,FCC IN2TX30) while holding it in the same spot. Maybe that has something to do with how the hub interprets a learned command vs the actual signal sent by the remote?

Ok, that smaller delay might be an artifact of the way we’re transmitting the signal today. It could probably be improved, but TBH I don’t see it on our near-term roadmap.