IR command from scan doesn't work when stored as a device command signal

(Note: this is all using the API on a Bond Home running firmware v2.15.8.1)

I’m using a scan to capture an IR command:

curl [...]/v2/signal/scan -d {
                "freq": 38,
                "modulation": "OOK"
        }

The result of the scan looks like:

{"freq":38,"bps":40000,"reps":1,"modulation":"OOK","encoding":"hex","data":"...."}

I’m able to replay this using signal/tx,

curl [...]/v2/signal/tx -d {"use_scan": true}

I then stored this as a signal (with “use_scan”: true), and it is used corrrectly:

curl [...]/v2/devices/4af352fb/commands/67b74616/signal
{
"use_scan": true,
"freq": 38,
"bps": 40000,
"reps": 1,
"modulation": "OOK",
"encoding": "hex",
"data": [...]
}

It matches the scan result. However, when I try to send the signal using /v2/devices/{device}/commands/{command}/tx it returns a 204 (expected I think), but the command doesn’t seem to be sent (unlike signal/tx, I don’t see the command do anything).

I’m not sure if I’m using the device commands incorrectly, or if there’s some bug.

Two things:

  1. have you attempted to set up a new device + do the IR scan and save through the Bond app in Advanced mode (vs using the API)?
  2. when you call the TX endpoint, does the Bond Bridge blink its blue LEDs?

(1) I’m not able to do IR scans using the app. By default, it seems to only look for RF, so the IR commands are not detected at all. Advanced mode only has a single “Frequency (mhz)” text box, but the IR signal is 38khz. Just in case, I tried 38, 0.38, 0.038, and none of those work.

(2) When I make the TX call, does Bond Bridge does not blink.

(1) when you’re in Advanced Mode you should change Signal Type to IR instead of RF or Auto; once you do that, you should not be able to specify a frequency at all (the option should grey out)

(2) since the Bridge is not blinking, it would appear it is not even trying to send - but I think it MAY have to do with the way you recorded using the API (I’ve not tried that for a long time, even with my IR devices).

You are using a Bond Bridge (black hockey puck shaped Bridge), not the Bridge Pro (big white box with Ethernet port), correct? The smaller Bridge / hockey puck is the only model that has IR capabilities.

Yes, that’s correct, I’m using a Bond Home (black circular puck). On the bottom, it has a model: BD-1000

The IR capabilities definitely exist and work on the device (since I can start IR scan via API, and replay using use_scan and it works).

Odd, because my BD-1000s show this in Advanced Settings:

Oh interesting, mine doesn’t display the “Signal type” or the “Search remote database”:

When I click the advanced settings, for a brief moment, I see the “Signal type” option, but then it disappears. I’m running firmware version v2.15.8.1, which I think is the latest?

I’m in the Beta firmware channel (which you can get to on the main app Settings page - not on the Bridge Advanced Settings).
2.29.2beta on my Bridge starting with BD serial (1st gen BD-1000) and 2.29.7beta on my Bridge with ZZ serial (2nd gen BD-1000).

It’s stable enough for me personally that you could give it a try and see.
And/or you could ask via in-app Support Chat if there is a reason why on, firmware 2.15.8.1 and app version x.y.z from iPhone or Android, that you don’t see the Signal Type or Database Lookup options in the Advanced mode of setting up a new device?

(@endy if you stop by here and have a quick explanation, this seems odd to me)

1 Like

Ah, I just replied on @prv’s other thread. Same advice applies: use the beta firmware.

1 Like

Thanks for the recommendation, I’ll try out the beta firmware in a couple of weeks (away from my device at the moment).

1 Like

Just wanted to confirm that updating to the beta firmware resolved my issues, thanks for the help!

1 Like