HomeSeer device buttons not working after edit of device buttons using the iOS App

I have a user reported issue:

For my TV’s I initially had only the ON and OFF buttons programmed using the iOS App. Subsequently, using the iOS App, I added the Toggle Button and used it to force the TV to select the correct video input (DirecTV). Now, the Bond App works fine, the ON, OFF and TOGGLE buttons do what I want them to do. However, on the HS side, the device buttons for ON and OFF no longer function. The TOGGLE button on HS works fine. They do all however make the blue light on the Bond Bridge blink.

It appears that somehow the plugin and the Bond Bridge is out of sync. Is there a way to refresh the plugin or the HS devices?

Update: I have tried restarting the plugin, reinstalling it, deleting the effected devices and letting the plugin recreate them., reprogram the Bond Bridge buttons using the iOS App… nothing appears to work.

I am using plugin, Bond Firmware: 2.10.21

Update 2: I have not tried removing the Config files. I have customized the look of the HS interface and removing them probably would mean a lot of redo of that work.

Update 3: Delete the plugin Config files didn’t fix it. I deleted the TOGGLE button programming on the iOS App, and the issue disappears. It appears that creating a new button on an existing device causes the problem. How can I create a new button on the Bond Bridge and sync the plugin?

I believe one problem is that the user is abusing the Generic Device to attempt to control multiple features. If you wanted to control “TV Mode” in addition to “TV Power”, you’d need to create another Generic Device.

Also, we do not support TV control. Kludging something with Generic Device might work, but Logitech Harmony does a better job for that use case. I don’t know how their HS integration is though.

Thank you Chris. HS does have Harmony plugin, I do use it - it’s great.

On the side note - are you planning to add more device type supprt, i.e. airconditioners, etc?