Fireplace not visible in smarthings

Hi I have a proflame 2 fireplace and a bond bridge ZZDIxxxxxxx firmware 2.28.0 I have a ceiling fan set up aswell.

When I connect to SmartThings the ceiling fan shows up but the fireplace does not. It is set up as a local device . I readded the fireplace but nothing

Any ideas?


Edit added screenshots

I added an additional fan and generic devices and none show up in ST

Here is the bond screenshot

Same problem with my Fireplace… it started a few weeks ago when it simply disappeared from my Smartthing app. Being looked at on Bond Support Request 59744.

After reading your post I am beginning to think Smartthings might be filtering out the Fireplaces similar to how Goggle Home filters out locks. I will do some playing and see if this theory is right or not.

Same problem here. It appears as any device that was set up as a “Device” (as opposed to a Light, Shade, or Fan) is not working in Smartthings or Alexa.

Since all we use is simple flame on / flame off commands (we rarely change the light, flame height, fan speed, or fireplace light), I eliminated the fireplace from Bond Home and taught the hub the on / off commands as a “Light” instead of a Fireplace. Sure enough Smartthings had zero problems showing the fireplace when I integrated my Bond Home devices into Smartthings. This certainly supports my theory that Smartthings is filtering out fireplaces with their Bond Home / Smartthings integration.

I have been in contact with Bond Support over the last couple of weeks, and today when I infomed them I was able to bring the Fireplace into Smartthings as a Light, I received the following resonse:

Sophia (BOND Home)

Jan 5, 2022, 15:15 EST

Hi Clarence,

Thank you for testing it out and providing more information to us.

We just received an update that a fix is already underway but no release date yet.

We will let you know once the fix is available.

Thank you!

Sophia from Team Bond

PS: The Fireplace never had any issue showing up in Google Home integrations, just dissappeared from Smartthings and could not get it to reshow in my Smartthings devices until I changed it to a “Light”.

@EtchayJr I came to the same conclusion. Added a bunch of things as fans items with the lite function only. My issue with this workaround is that if I day hey google turbo on living room lights the fireplace will turn on. I linked this thread to my support ticket aswell. Hoping there is a fix soon.