Cannot Add Bond Bridge Pro to HomeKit

Finally got around to setting up my Bond Bridge Pro last night. It is running firmware version 3.13.8. I am using Bond app V2.45.0 on iOS 16.4.1 (a). The initial Bond Bridge Pro setup went fine, but when it came time to add the bridge to HomeKit, I ran into issues.

Both the iOS device (iPhone) and the Bond Bridge Pro are on the same subnet. When following the Bond HomeKit integration instructions posted, it takes the iPhone a LONG time (5+ minutes) to find the Bond Bridge so I can attempt to add it to my home, and then after providing the setup code, the iPhone takes a LONG time to try and add the Bridge, and then eventually errors out with something to the effect of, “Accessory cannot be added because it cannot be found.”

Has anyone else run into this issue before? How can I fix whatever problem is plaguing my install so that I can add the Bridge to HomeKit?

Just go give an update:

I made sure all HomeKit hubs were up to date and updated all iOS devices.

Via the Home app on iPhone (running 16.5), I cannot even attempt to add the Bond Bridge Pro to my home. I provide the setup code, and nothing happens.

Memorializing a fix in the absence of vendor support…

I originally had the BBP networked via wired connection. After the “HomeKit cannot even see the BBP” issue described in my second post, I decided to reset the BBP and switch it over to WiFi.

On the same network, but connected via WiFi instead of wired connection, I was able to add the BBP to HomeKit without issue.

Not sure if this is a BBP issue or a HomeKit issue, but my problem has been solved for the time being.


Thanks for the post, @itswilly - this may be of interest, @endy.

1 Like

Good to know!

I know that it works with mDNS (Bonjour, the Apple implementation), but didn’t get into the details to know why it won’t work when wired connected.

Thank you very much for sharing it with us.