Bond Pro + tvOS 18 (beta) HomeKit hub issue

Hi! I have the Bond Pro bridge (BD-1750-PRO) and it’s on the latest firmware (4.5.17-beta.) It is configured to control 7 shades and 1 set of drapes in my house and it’s been working well for a long while now.

I also have 4 AppleTVs around the house, 3 are wired and one is wireless. I updated one of the AppleTVs to the Developer Beta of tvOS 18 this week to test another app I’m working with. Everything else is working fine, however, when that AppleTV, with the latest OS, takes priority as the primary HomeKit hub, I see that I lose the ability to control the shades and drapes that are linked to the Bond Pro bridge.

I have tried turning HomeKit off and on again, in the Bond app, to no avail. I have not tried removing the Bond Pro bridge from HomeKit and adding it back because I was skeptical it would help and I didn’t want to lose my settings, room assignments, schedules, automatons, etc. associated with my drapes and blinds.

The only way I can regain HomeKit control of the drapes and shades now is by unplugging that AppleTV, so one of the other three AppleTV’s (still on tvOS 17.5.1) can handle the HomeKit hub responsibility. At that point, control of the shades and drapes return to the Home app. Once I plug that first AppleTV back in though, Bond control is lost once again. This is 100% reproducible. Prior to this tvOS 18 update, if didn’t matter which wired AppleTV was prioritized as the primary HomeKit hub, everything worked regardless. Now, this appears to be an issue that exists with tvOS 18 specifically, which will be releasing widely in a few months.

I have many other smarthome devices and many other bridges from many other manufacturers, and none of them are having any issues, for what it’s worth. It’s just the Bond bridge and it’s just when that one AppleTV running tvOS 18 beta is powered on and prioritized as the primary hub, that HomeKit loses control of Bond-connected drapes and shades… Which happens whenever it is plugged in, because it’s software is “the latest.”

I also know that tvOS 18 introduces a way for the use to choose a preferred HomeKit Hub: You Can Select a Preferred Home Hub in iOS 18 - MacRumors
However the only way to enable that setting is to first update all the AppleTV’s to tvOS 18. And in light of the issue reported above, I am loathe to update any of the others now, at least not until much later in the public beta cycle or after actual public release.

All of this to say, this is a heads up, that I believe the HomeKit compatibility of the Bond Pro bridge with the latest beta firmware, is having a serious issue with the Developer Beta of tvOS 18. I’m leaving that AppleTV unplugged for now but is there anything else I can do to troubleshoot, or is there more information I can provide so Bond is able to prepare ahead of time and get this fixed for when tvOS 18 is publicly released? If not hopefully this advance notice helps the development regardless.

I’m obviously happy to volunteer as a beta or even alpha tester for any updates you provide. Thanks!


Hey Fofer, thank you for taking the time to so clearly explain the issue you’re facing with the HomeKit support on Bond Bridge Pro. I can tell that this is an important piece of the puzzle in your smart home, so I’m really feeling pretty bad to say that I don’t think we will be able to address the issue.

The reason is, the library that we use for HK support (from ESP, wrapping Apple’s library) is not receiving updates anymore, and HomeKit protocol is kind of like alien technology to us.

Matter seems to be the preferred route now, but alas we do not have that development started yet for the Bridge side. (Though it seems like it’s time.)

So in this case, going (back) to HomeBridge may be the only viable option until Matter arrives. (Though as of now it’s not clear if we need new hardware to make that happen.)

1 Like

Thanks for candor, @merck. With all of these ingredients constantly in flux I can only imagine how difficult it all is to support. Of course the sole reason I chose the Bond Pro bridge was for HomeKit integration, and if this were to break for everyone soon with tvOS 18, including those beta testing HomeKit on the non-Pro bridges, I know there would be a tidal wave of disappointment ahead.

Fingers crossed Matter support ultimately makes this easier for everyone involved.

THAT SAID, I do have some good news to report:

After a handful of beta updates to the Bond Pro bridge, as well as an update to the first PUBLIC beta of tvOS 18, HomeKit is now working again over here. I am once again able to control my shades and blinds via the Home app, even when that updated AppleTV is prioritized as the HomeKit hub. Phew! Crisis averted. :+1:t2:

During this month of incompatibility however I considered deeply why HomeKit control was important to us (as we also have Alexa and scheduled automations to help.) I realized the one functionality most useful, was the ability to control the shades and blinds from macOS, my laptop (via the Home app.)

I would like to submit the request that the Bond app in the App Store be allowed to work on Apple Silicon Macs too. I was able to run this app perfectly on my M1 MacBook Pro back in the day, via sideloading with macOS 11.2.3, but sadly Apple removed that flexibility with 11.3, now requiring that developers “opt in” to allow that compatibility via the App Store officially.

It’s the same iOS app, and it runs seamlessly on macOS without any changes needed, so could Bond please consider checking that box in their App Store developer settings and allowing their customers that same flexibility once again?

The ability to just use the Bond app directly on newer Macs with Apple Silicon would go a long way to reduce the reliance on HomeKit for many of us.

As always I”m happy to test anything out and answer any questions to help with the development of your products. Thanks for the consideration!

1 Like

Thanks for letting us know about this. Apparently Apple required us to explicitly opt-in again, which we have now done. :white_check_mark: Unclear exactly how long it takes to become available or if it need wait for the next iOS app submission.

1 Like

Great news, thanks!!

Reporting back, yes that was fast! I will note that as of now, the Bond app is not showing up via search, but I was able to download via this App Store link (copy pasted from my iPhone)

In the days ahead I’m thinking the description will change too, to include mention of this new compatibility.

Regardless, I was able to download it. And the Bond app is once again working nicely on macOS, my M1 MacBook Pro is happy. Bond is back in the Dock! Very handy. Glad I asked! Thanks. Much appreciated! :slight_smile: