Any chance of supporting Nexus 21 lift controls

I have an RF remote for a TV lift system with two commands: Up and Down. Currently when I try and get the Bond Bridge to learn from the remote it just gives me the oops response after the 30 seconds. Is there anyway to get it to learn from this remote?

Can you post the FCC ID from the back of the remote here? And photos of the front-back of the remote and IR or RF receiver?

I tried to get the information from their website and manuals, but couldn’t make out the details.

L

Pictures of the remote. This is RF, it may be difficult to get to the receiver up in a recessed cabinet 10 feet up, I can try if you do need it though.

Attached instructions, page 26 has the receiver.

(Attachment L75I_M.pdf is missing)

Thank you, Brent. Those bits are sufficient.

Frequency = 433.92 MHz, so technically the BOND Bridge radio should support it.

When you were attempting to teach the remote commands, did you try going into Advanced and toggling OFF the ‘Search Remote Database’ switch? Also, you could put in RF and the 433.92 MHz frequency.

I tried that three times, still no go. Maybe they are doing something tricky to keep others from controlling their hardware.

@CrossfireX you can also try tapping the Up button repeatedly and very rapidly (“mashing”) rather than holding it down during the Bond’s scanning.

1 Like

I was mashing down actually, I could try holding it down instead, but since up and down are discreet events, I doubt it continuously broadcasts while down. I also tried alternating between up and down rapidly.

Believe it or not, on most remotes, holding down the button results in a continuous stream of packets being transmitted, even for “discreet” events like “open”. Sometimes the transmission from a tap is too short (and transmissions from mashing too sparse) for the Bond to capture. But normally it’s not so hard. Something different may be going on here.

Amazingly, they disclosed their RF protocol as part of their FCC filing! https://fccid.io/XBE-HB1XRF/RF-Exposure-Info/RF-Protocol-2513828

Everything looks OK… I think the next thing for you to try is this:

  1. try getting farther away (~10ft) from the Bond Bridge when programming. It may be that this transmitter is strong and you’re too close.
1 Like

Still no good, I tried several distances, holding down and mashing with auto frequency and the stated frequency. I appreciate all the help, not sure why this is being so stubborn.

Hmm. Are you using any other 433MHz devices with Bond Bridge? If so, that would eliminate a Bond hardware issue. (unlikely)

The next step that we’d try is to use an “RTL-SDR” dongle to see what frequency the remote is actually using. Sometimes the FCC docs don’t match the reality. We use these dongles: https://www.rtl-sdr.com/buy-rtl-sdr-dvb-t-dongles/

The other path is, to reach out to Nexus (or LINAK, the actual controls manufacturer) and ask them if they can establish Bond Bridge support. A number of device manufacturers are starting to do this, and they are generally in a better position in terms of inside product knowledge to debug the issues than an end user.

The only device currently on the Bond Bridge is a Kichler Ceiling Fan. I don’t see the frequency listed in the information (A3a template).

The dongle sounds interesting but Amazon shipping is ridiculously slow now for things like this. I had originally bought a Sonoff smart switch as you just need to send power to one wire on the motor control to activate down and another to activate up with a
common return. The Bond is a much more elegant solution and I will continue to pursue it but it is likely to take quite awhile.

Nexus 21 is one of those brands I wouldn’t have bought given the choice, they do not want to play with others and force everything through authorized agents to control pricing. Like the Crestron Pyng I ripped out and threw in the trash, I couldn’t even change
a room name myself, had to pay the dealer to do it.

I really appreciate your help, your product is great. I plan to put all my RF controls onto it as I can.

2 Likes