With beta firmware, cannot add remote

I had been having some small issues with my ceiling fan remote previously and have had a support case open for a long time. The remote has FCC ID IN2TX45. Support has made progress, making the situation much better after pushing a new test panel for this remote to my bond back on December 5th. Joining the local API beta has made the situation dramatically worse. Upgrading the bond firmware did not go well, the device would not work properly on the network without a full factory reset. After the reset, I was able to get it back on the network, but now it simply will not work with the IN2TX45 remote. It claims to read the signal when I go through the training, lighting up green right away, and giving me an option to test. But, it never works. The bond is never able to send a working signal to the fan. I have two of these fans, and neither works. I have tried every button on the remote, none of them will train properly. With no working remote to test with, I cannot even do any testing with the local API. Any ideas?

Try rebooting the Bond. I had the same behavior and was able to add a remote after rebooting. I’m now back to being unable to add a new device. I’ll try another reboot tonight.
Makes me wish there was a reboot command in the api.

There is. And I think I used it successfully but I can’t 100% swear to it.

PUT /v2/sys/reboot

1 Like

Oh sweet. I thought I’d read the whole doc, this will save me a bunch of time if this is actually an issue with the current beta. Thanks!

@j4nd3rs0n: Does your BOND serial number start with ZZ? (large differences in the RF stacks between A/B BONDs versus Z BONDs, that’s why I ask)

It does not. Starts with BD. I will keep trying, but also cannot get any API call to work except getting the token within first 10 minutes of boot. I always get:

curl: (52) Empty reply from server

This is true no matter what kind of call I try. I will try to reboot again and add remotes later today.

Are you using the -H header for the calls? Documentation shows an incorrect -X.

Now that was a quick response. I thought the -X option was strange, but went with it anyway due to the documentation. Changing to -H allows me at least to make API calls, which is an excellent improvement. Sincere thanks! Would be nice if the Bond folks would change the documentation, it is still incorrect and should take like two minutes to fix. At least now I can test the API with my two Minka Aire ceiling fans even if I cannot get the IN2TX45 remotes to pair. I will reply back to this thread later once I try the IN2TX45 later today.

1 Like

Yes, some other folks have found that too.
(Cannot get devices from local API)

I do have a running documentation update / correction request thread but haven’t seen any updates on it yet:

Can you please describe the differences in the RF stack on the newer Z BOND devices? Does it cover additional frequencies, have greater range, etc?

Exactly the same product behavior and specs. It’s only differences in the software stack.

I tried rebooting the BOND multiple times, no change in behavior on the IN2TX45 remote. Is it possible to look up my support case and push that test panel to my device to see if that works?

Following up on this thread, with the 2.6.7 firmware version I can now program my remotes successfully.

That’s awesome news!