IFTTT integration no longer working after upgrading firmware to 2.15

I upgraded to, and now my Google integration through IFTTT isn’t working anymore.

I tried unplugging and rebooting my BOND device. I tried resetting my password to the integration on IFTTT. what else can I do?

Here’s an example the Bond staff made showing how to integrate IFTTT (if you really need that still), through SmartThings.

I’m curious what options you gained with Bond → IFTTT → Google vs Bond → Google? Originally the native Bond → Google integration support wasn’t as full featured as it is now, I think.

Good afternoon,

Let me just say first that I have always found the BOND staff to be helpful and interested in their own product.

In regards to IFTTT, I have well over 150 applets. I’m a power user, I pay for a pro subscription, and I have a custom smart home set up. It’s a mix of alexa, Google, BOND, curl, IFTTT, macro scheduler, dropbox message passing, and a custom perl daemon that I wrote to handle all of the things that none of these companies agree on. I work on my smart home fairly regularly.

One of the features that IFTTT has that keeps me interested as a customer is that I can use curl to activate applets directly outside of using a smart speaker. Using just the Google or Alexa ecosystem is unreliable. My Google home currently doesn’t understand BOND commands even when added to my Google home app. I’m currently working with BOND support to see why that is, but I’m losing hope. I will try SmartThings because it seems like IFTTT is the only reliable way to get smart speaker agnostic access to BOND.

Now, it is true that IFTTT occasionally has latency problems and some queueing shenanigans. That does happen. But the situation I’m in right now is zero smart speaker access to BOND, which has ruined that part of my smart home ecosystem. I’m in repair mode right now. I upgraded my firmware from 2.5 to 2.15 hoping to resolve some glitches, but instead I have completely disabled that part of my smart home. Yeah, I’m disappointed, because it was working even if it wasn’t perfect.

I use an ISY994, RPi, and lots of custom stuff so I understand how frustrating it can be when things break in the careful balanced tower of protocols and products.

I prioritize local control and try my best to have any smart speaker / assistant integrations I handle to be through my own ISY integration / exposure to Google Assistant, vs native products’ voice versions. (Who wants Google or Alexa to have 20 different skills or services which don’t update each other or keep in sync well, when you can have 1 service that you control?)

I’m brainstorming what I would do in your shoes… since you have a perl daemon handling things… could that same system not handle directly Bond as well through its local networked API?
Next hurdle would be, I know you’re also saying you want platform agnostic smart speaker access (agree with you there!) … So maybe the IFTTT and / or SmartThings integrations are still necessary for your setup to accomplish that?