Fan speeds command will not work still for me

I have read through the posts. I have tried all the recommendations but still nothing. I have tried set and turn on with the device name an speed but I get the great apology. I also notice that in the google home app the fan light will turn on/off via the app but the fan is shown as off line and can’t be controlled there. Not sure if this has something to do with this.

I can turn the light on and the fan on as long as I don’t ask for a speed things work.

I have tried to set up a routine thinking I google doesn’t understand me but I was able to get it to work one time but so far not again. I even setup the same routines for my other two fans but nothing there.

I am moving my house from Alexa to google and this is one of the last sticking points.

Thanks for any further suggestions. I am on version 2 of software platform but still had an issue on version one. My bond is about 4 years old so not sure if this older hardware can be an issue.

Blockquote

The older hardware has some issues, but it’s mainly WiFi-related, nothing that’d result in Google Home not working differently than the new hardware.

Google handles the voice -> intent mapping, and recently there was a change:

  • “Set to speed #” - Not working as of 11/29/19
  • “Set speed to #” - Working as of 11/29/19

Have you tried the second phrasing?

Yes I have tried both set and turn with no luck with either.

I accidently found that using the room name rather than the fan name works better with Google. EG I have a fan named “Fan Alpha” in room “Bedroom 1”.

“Set Bedroom 1 fan speed to 2” almost always works whereas “Set Fan Alpha speed to 2” invariably fails.

This of course would be problematic if a room has multiple fans. I have not had to deal with that yet - but probably will soon.

In this case, I’m really not sure what could be happening here. I recommend you contact customersupport@olibra.io if you haven’t already done so.

Also, @joaoricardo can maybe provide more insight.