Somfy Shade Groups Issue

Hi all! I have to say that I’m really loving this product. The functionality is incredible, including an API, WiFi, etc.

So, I have been successfully using my Bond Bridge for several months to control a bunch of Somfy shades without any issues. I’m using the latest firmware, version v2.10.21 . On the Somfy physical remote that came with the shades, I have a particular channel (#14) which is set to control 6 screen shades at once as a group. Another channel (#15) controls a different set of 6 blackout shades, and channel #16 controls all 12 screen / blackout shades.

For some reason with channel #14, when I try to add a new “Remote Control” in the app, and then go through the pairing process, not all 6 shades jog. I’m only able to get some of them to operate. I’ve tried the setup repeatedly with mixed results. Sometimes different shades jog and others don’t within the group of 6. Channel #15 and #16 groups work fine in the app to control all the shades in the group.

Everything always works fine through the Somfy physical remote control. I’m not sure if I completely understand how the channels work for groups of shades, i.e. is it a very long RF sequence that has to be sent to each shade in the group. But somehow the Bond Bridge is not able to capture the RF stream correctly for this channel. I’ve even tried adding the remote control as a “Device” instead of “Shades” and the Bond Bridge is still not able to learn the pattern.

Anyone experience the same issue or have any suggestions? I’m really thinking it’s a bug and not a physical limitation as other groups work just fine.

Thanks! Glad you like it.

Yeah, that’s basically what’s going on, there’s an “address” in each signal. Each channel uses its own address, and each Bond Bridge Somfy device uses its own address.

My first inclination is that your receivers on the few shades that don’t jog in channel #14 are “saturated”. Each receiver can only be paired with 12 addresses (whether that’s a physical remote channel or a Bond Bridge remote). Once it has that many, it will stop responding to the pair signal from a new remote.

Since you seemingly only have 3 addresses paired with these problem shades (channel #14, channel #16, and the Bond remote that matches #16), this seems unlikely, but I have seen it from other users. Maybe the receivers were paired with quite a few other remotes before purchase?

This is really useful information. With this, I can eliminate a few other potential causes in my mind: it’s clearly not caused by the distance of the Bond Bridge to the receivers, or by the receivers being a very old model that expects a slightly different signal.

Hmm… how to test this. If you had one extra Somfy RTS remote lying around, this would be very easy to test: just try to pair with the unpaired remote.

If you don’t have a spare remote lying around, I guess you could try to pair channel #15 to the remotes in channel #14. If you get the same behavior as with the Bond Bridge, this confirms that the receiver is saturated, if not, we’ll have to brainstorm further. Either way, when done, you’d just unpair all the remotes that responded to the pair signal. (This is done with the exact same procedure as pairing them)

Another solution: if your receivers/motors are pretty easily removed from power, you could try a factory reset, and then pair with #14 and #16 and the two Bond Bridge remotes. This is what you’d need to do if the receiver is “saturated” anyways. Here’s a two-minute video on how to factory reset a Somfy RTS motor.

Jacob, thanks for the quick response! I think you are onto something regarding the “receiver saturation”. I don’t have a spare remote lying around, so I can’t try pairing to a new remote to test it that way.

I did however, try the “unpair” function in the app to remove 3 of the individual shades that are also part of group #14 , so I was able to unpair #2, #4, and #6 successfully. After doing this, when I tried to add the #14 group back into the app, I then had #4 and #6 responding to the “pair” function and jogging. I’m still not getting all 6 shades to respond, so I’ll looking at the factory reset option next.

I’m currently using the battery operated “Sonesse 30 WireFree RTS Li-ion” motors, so they don’t have a physical power plug. They have their own factory reset procedure via a button on the unit itself, but they warn that if I do a factory reset, my physical remote will stop working. So, I’m still researching on how to reprogram the physical remote and limits once a factory reset is done before I try it.

I’ll post an update once I’ve had a chance to play around with it some more.

1 Like

All, I wanted to post an update to this issue. I finally got around to doing a factory reset of all of my Somfy Motors. They are the Sonesse 30 WireFree shades, and I have about 12 individual shades being controlled by a 16 channel remote. I have 2 shades per window, 1 being a light-filtering screen and the other one being a blackout. Each motor can store up-to 12 different remotes (as Jacob mentioned). So basically, 6 windows, with 2 shades each.

I have never had problems controlling everything via the remote, including groups, however, I did experience issues pairing with the Bond Home app. For instance if I had a group, not all the shades would open and close, even though they “jogged” when I hit the programming button on the physical remote.

After the factory reset, I added each motor, one-by-one to channels 1-12 on the physical remote, respectively, setting upper and lower limits, etc.

Then, still on the physical remote, I needed to create a group for “All Screens”, another for “All Blackouts”, and then a group for “All Screens and All Blackouts”. Let’s say that the “All Screens” group will be on channel 14 and the “All Blackouts” group will be on channel 15. I then added all the screens individually to channel 14 and all of the blackouts to channel 15.

Now I needed an “All Screens and All Blackouts” group to be created on channel 16. I decided that instead of adding all 12 individual shades to channel 16, I would try to add channel 14 and channel 15 to channel 16. It actually worked!

I tested the physical remote, and everything works nicely. Next, I went into the Bond Home app, deleted all previous devices for these shades / groups, and then added all 16 channels through the app, one at a time.

Everything works perfectly now! I hope this helps anyone in the same situation.

So, I had 1 question on the Bond Home device for Jacob or the folks at Bond Home. In the situation that I had prior to the factory reset, and re-pairing with the Bond Home device, I thought I could use the “Add Device” option, instead of the “Add Shades” option. This didn’t seem to work. Bond would register that it captured the signal from my Somfy physical remote (and turned green), but when it tried to reproduce the signal, there was no response from the Somfy motor. I thought that I would just be able to “learn” and “replicate” the same RF signal that the physical remote was producing to get around my issue and operate the motor.

What is so special about the signal coming out of the Somfy remote that it can’t be learned / reproduced by Bond as a “device” and therefore requires specific Somfy support?


Ok, an update to my previous post. I think I answered my own question. It looks like the Somfy RTS protocol uses a “rolling code” stored on both the receiver and transmitter which is incremented every time a button is “pressed”, in order to prevent replay attacks.

Therefore, just capturing or learning the the signal from the physical remote and repeating it back with Bond will not work (Adding Remote -> Add Device). So specific Somfy support is required in Bond (Add Shades -> Somfy). Kudos to the Bond team for implementing Somfy support in this product!

1 Like

That’s exactly right!

1 Like