Fan off vs power off

Is there a way to differentiate between “power off” and “fan off” for fans with lights. I have lights on almost all my fans and the power off command turns both off - asking Alexa to turn the fan off has the same result. When the light goes off with the fan off command it also screws up the tracking for the toggle lights - the Bond still thinks the light is on. The remotes do the ability to turn off the fan while leaving the light on. One actually has a completely separate “fan off” button, the others have a single fan speed button that rotates through 3-2-1-off. I can’t even delete and re-record the commands because I don’t get that option for half of the fans, just a “reset to defaults” option.

I can get the FCC id’s if you need them, in the app one is listed as template A1a, one is RCF98v2, and the other two don’t have a template listed.

The RCF98v2 also has light tracking issues - it refuses to not send commands no matter the state.

This is an expected bug, I’ve been working on a fix recently and am about to release a beta firmware with a fix.

This is the A1a, right? The signal that this button transmits should be what the Bond is transmitting when you say “Turn Off {Device Name}”.

Do these remotes actually have “Power Off” buttons? Can you turn off just the fans with the Bond Home app?

I’m thinking this is due to an interaction of Alexa and the Bond Bridge, but I may be wrong.

I do know of remotes with “Power Off” buttons, but they also have signals to just turn the fans off, so at this point we haven’t exposed them to the user. A1a and RCF98v2 are two of the most common remote templates, and we think we know them pretty well, but anything can happen I suppose!

Yup, it’s the A1a that has a separate “fan off button.” I’ll have to check again what it’s doing, it might be perfect and I might be confusing the issue with the kids room fans with that one. The A1a fan is the one with a separate up and down light and they do strange things with voice commands.

My husband will particularly appreciate the fix for the light on the RCF98v2!

I should have written down the id’s for the other two fans last night. They’re both the same Home Decorator’s fan with a “thermostatic hand-held remote control.” There’s a picture of the remote on Home Depot’s site: The big power button on the top turns off both the fan and the light. That’s the command the Bond app seems to be using. The single button with the fan picture and LED’s on it rotates through the fan speed 3-2-1-off like a pull cord would.

On an unrelated note, my husband just got a new computer and it came with this ridiculous case with rainbow spinning lights controlled by their own remote. I looked at the tiny remote and thought "this is going to get lost so fast, I wonder if it the Bond could control it. A minute later, I could turn off the lights on my husband’s computer with Alexa. :smiley:


We’ve got a strategy for this on our roadmap. We want to expose the up and down lights independently. I do have a possible way to improve your experience with these lights right now though: enable state trust in the device settings. Here’s what the behavior should be with this trust flag enabled:

  1. Both lights are on → “Turn off light” → Both lights turn off → “Turn on light” → Both lights turn on
  2. Top light is on, bottom light is off → “Turn off light” → Top light turns off → “Turn on light” → Only top light turns on
  3. Like 2), but with top and bottom switched

Basically the Bond Bridge should “remember” which light was last on. You could use the app to change which of the top/bottom lights is on.

So we want to extend this with “Turn {name} top light on”, but it’s still a ways out.

Without “state trust” enabled, the behavior of a two-light fan would seem a little erratic: it always sends a toggle for the light it believes was the last light on.

This is the remote I was hoping to see! This makes more sense now. This is the one style of remote that I’m aware of that has a “turn everything off” button. I assume you created this remote with the old app?

I suggest you try re-recording it, it should come up as “B2” and you should get a slightly different version that uses the “Speed 0” signal to turn the fan off, and doesn’t populate a button with the signal from the top “Power” button at all. (We eventually want to add it, but it’d need a special new action that is equivalent to “TurnOff” + “TurnLightOff” that is afaik only present on this remote)

Keep your current version of the remote until you confirm that the new one works, just in case, so we could compare any differences in signals. Let me know if it doesn’t behave as described and I’ll look in to it.

I probably did create those remotes with the old app. I will try re-recording when I get home and see what happens. It sound like a nice easy fix. Yay!

I’ll also test with the trust state enabled on the A1a.

You obviously really know your remotes! I really appreciate how supportive you and knowledgeable you are. It makes me happy to have one of your products.

1 Like

Kitchen and master bedroom both have quirks with the lights, but paying more careful attention, the are not turning off inappropriately with the fan. That’s great.

The other two fans stubbornly refused to register as anything other than F2 (3 speed) in the database. I’ve tried getting it to look up every other button, but the database is quite set on it being an F2. Every function on that template does work, but it loses the dimmer, breeze and timer and the “fan off” command still turns off the light. Can it be brute forced?

Based on the results here, maybe I don’t! :rofl: I’ll bring this to the attention of our team’s remote expert on monday.

1 Like

No, I’m still impressed with your knowledge. :slight_smile:

I did try creating an “F1” fan via api, but it gave me an error saying the template name wasn’t valid. I can try again when you hear back from the remote super experts.

He’s investigating this today, he suspects there might be two distinct ways (“LightOff + TurnFanOff” vs. “TurnOnlyFanOff”) that receivers respond to this signal.

This is available now in Bridge Firmware v2.10.15. If you’ve got a chance, give it a try and let me know if it doesn’t behave as expected!

Awesome! I will let you know when I get home.

Hm. I assumed there were different signals being sent because they’re on different buttons.

Yeah, this is correct, ignore my previous post. We’ve just fixed this! I’ll get a v2.10.15 out to beta with the fix shortly.

Wahoo! Will I have to re-program the remotes? Will I lose the dimming and timer functions?

The dimmer is already in the definition, but the timers aren’t, we’ll add them real quick before the release.

Sweet! Honestly I didn’t know that the light on the fan could dim until I got the bond and the database search gave me a dimming button. The same thing happened with my “A1a” kitchen fan - the remote I have doesn’t have any dimming buttons, but the lights happily begin dimming when the bond commands them.

I’ve just released v2.10.15 to beta. It should have the correct “off” behavior and new timer buttons, give it a shot!

Probably a hold-to-dim situation, but yeah, it seems this often goes undiscovered.

Almost perfect! I get all the commands except breeze/random and they all work as expected.

Only quirk was with the app itself. After I recorded the “new” remote and tested the commands and confirmed, it put me back on the page for the new fan saying “you have no commands” and asked if I wanted to restore defaults. I said yes and they all appeared. That happened again after closing and reopening the app. But after the second time it “took” and all the commands re-appeared immediately when I opened and closed the app a few more times. I’m not sure if it’s something with the template or the app and it resolved itself, but I wanted to let you know.

The fix for the RCF98v2 is awesome.:slight_smile:

That sounds bizarre! I’ll pass this on to the app guys in the morning, to see if they have any ideas as to what might be happening here.