Ceiling fan light on/off does not work properly

Hi All,
I have several Ceiling fans in my home, set speed turning the fans off and on works. my issue is with the lights. they will not turn on with Google Turn on living room ceiling fan light. it will turn on when I say. Google Turn off living room ceiling fan light. asking it to turn off turns on the light. but when it’s on I can say Turn off living room ceiling fan light and the light goes off. this is the symptom for all my ceiling fan lights. did I set something up backwards? the remote controls aren’t really an On/OFF it’s more of a push button toggle I’d say …


If you are using the remotes AND Google Assistant, you will have this issue on any fan that originally only had a toggle-light button.

Best bet is to throw your remotes in a dark drawer, enable Trust State in the three-dot menu on the fan in the Bond app, and then only use Google Assistant.

Bond cannot add a discrete light on command and a discrete light off command if they didn’t exist, so when you’re saying “turn light on” or “turn light off”, it’s just sending the original “toggle light” (hence why the original remote being used will mess with what Bond knows to be the last state - Bond doesn’t listen for original remote button presses normally [only during original device set up in the app])

Thanks for the response, I’ve not used the remotes ever since I set them up with Bond. I’ve just gotten use to saying to goog turn blah room ceiling fan light off to turn it on and the same to turn them off. I checked the kebab menu in the upper right and I do not have anything associated with TRUST in there. I checked all my 6 of my fans that are setup, none of them show Trust State off the kebab menu. I guess could tell goog to associate when I say an on command to turn it off, hence actually turning it on through bond via goog, I’ll give that a shot…!!! and report back.

Once you’re in the kebab menu (I like that phrasing), do you see Advanced?

very odd, I do not have those options in mine at all.

Bond Device

toggling that on would be easier, because I setup the goog to do the opposite of what I say. but it still gets confused, sorta works … haha. yes. kebab… :slight_smile: great reference and yummy as well … .hahahaha

Since you don’t show a Template, either, did you record each remote keypress, or did Bond “find” / figure out your remote after one or two keypresses?

If you did record each keypress, if you go into kebap menu on the device and say “Edit Commands”, I’d suggest making sure the “Toggle Light” in the top Light section is what is green / recorded, vs any of the other options (Light On / Light Off).
You can record it if it is NOT green by tapping on it; I’d then recommend deleting (with the little X) the Light On and Light Off commands from that same screen - if indeed those were the original recorded commands.

Then, once you save and back out, see if you have “Trust Tracked State” toggle now?

Awesome!!! that did the trick my friend!!! thank you very much … I removed the on/off added the toggle, set Trust and normal goog on/off command works now. Win! :sunglasses:

Thank you!