Revisiting SmartThings

Hey all,

Last week we finally got back around to debugging our SmartThings integration. There are three big problems that I’m aware of:

  1. An issue where authentication fails after ~24 hours of enabling the “Bond Home” ST app. This results in network errors after the successful control of a device, and the state never updating. If you delete and then re-add the Bond Home ST app, it should be fine for another 24 hours. I believe we’ve fixed this logic! I’ve just deployed a patch. You probably will still need to delete and re-add your “Bond Home” SmartThings app! But this time should be the last time
  2. An issue where devices start duplicating. It seems this is due to not properly reporting when devices are deleted. We need some tweaks in another part of our backend to address this. We’re hoping to patch this within the next week or so.
  3. Our SmartThings integration does not currently support “cloud” devices. Our current focus right now is to get rid of these cloud devices in favor of fully local devices. Over the next few weeks we will push through a cloud to local migration that’ll get all your devices working.

After these three roadblocks are out of the way, we’ll start expanding the integration to support more device types: motorized shades, fireplaces, and fans with two lights.

4 Likes

I deleted the fans in my ST app and then the bond integration

Waited a few minutes and authenticated Bond again in the ST new app

It did not find any of my fans… nothing shows up in ST

i also dont see any logging for the Bond app under ST Live logging

Your fans are all cloud devices, which are not supported by our ST integration. I already have local versions of all these particular fans working in a firmware build we’re testing internally, but they’re not yet present in beta or public builds. I’ll get these into your hands as soon as possible. Right now we’re just fixing the apps to accommodate such devices and testing the firmware.

As for your shades, they are locally-controlled, but we haven’t implemented discovery of shades yet. I’ll do that (and fireplaces, up/down lights) next week.

As for the “deleted devices stay around forever” issue: the fix is being reviewed. Should be able to deploy it in the next couple days.

1 Like

Thank you for the update, it helps show progress is being made.

Can you clarify something, will the ST integrations work with the old bond bridge once the 3 above mentioned roadblocks are cleared or are there other challenges for that to work?

Yes, it will work, the only requirement would be that you’ve got a V2 Bond account, and your Bond is on V2 firmware. Your old account will migrate automatically when you log in to the V2 app, so that’s not a huge roadblock.

Great! Are there any limitations? I see mention of ZZ Bond Bridges, I believe mine is not so will I still be able to upgrade to v2 when its available?

Yes, definitely! The only real differences between your Bond Bridge, which I assume has a serial starting in A or B, and one with a serial starting in Z (the newer hardware) is really just performance: faster boot, better WiFi compatibility.

All the planned “V2” features will be available for both of these types of Bond Bridge at the same time.

Thats great news! I will say if that information was readily available somewhere that would be really helpful for others I image. (if its somewhere already I couldn’t find it).

I’m currently using the 2.14.0-beta1 app with firmware 2.7.19-beta, and was able to add my formerly-cloud-based fans to the bridge. Everything looks good and is working as expected within the app. I’m very pleased. However, I am not able to view the devices in SmartThings, even after removing/re-adding the Bond service. Is that still the expected result?

Looks like all of your remotes are of the same “Family”: RCF98v2 — they remain cloud devices in firmware version 2.7.19. Remote families starting in anything other than “R” are the ones that are created locally v2.7.19.

Your remote is one of the most common state remotes though, so I really want to get it working ASAP. I almost have it working in the office, and hope to have it ready in a beta release by the weekend

I just released v2.8.1, which supports local control of your fans, try it out! Your beta app should offer you the upgrade.

Eventually we’ll migrate these down from the cloud automatically, but for now you’ll just need to re-record them. I’ve got one of these fans in the office and it’s working well with SmartThings, please let me know if you encounter any difficulties.

1 Like

That was quick! I’m not able to upgrade the firmware as of yet. Is there a delay?

Check now, it should be available.

I’ve made more progress here. I believe I’ve solved the “token refresh” issue. That issue is: losing state refreshes and instead seeing constant network timeout popups 24 hours after adding Bond Home to ST… Please let me know if you still see this issue. Deleted devices seem to show as “offline” when you try to control them, instead of deleting from the SmartThings app as I’d like to happen. Still troubleshooting this one…

I also added a basic Somfy shades controller: for now it’s just an On/Off switch for Open/Close, we’ll need to find the right controller to work in the “my” Preset position signal later.